Does not have enough resources


Trying the install script for Google gcp. Was granted 1 gpu after request.
Now getting

ERROR: (gcloud.compute.instances.create) Could not fetch resource:

  • The zone ‘projects/firm-tracer-244111/zones/us-west2-b’ does not have enough resources available to fulfill the request. Try a different zone, or try again later.

So some comments about it, but not sure what is the simplest way to solve it.



Hi I’m having the exact same issue, please @ me when you have a solution! GC gave me this in an email

Changed Quota:
| Changes | 0 -> 1 |

My VM Instances is empty, and I get the same error in your post.

1 Like

I’m having the same issue. Please let me know if there are any solutions. Thanks!

I have also been having this issue with an existing instance (–zone=us-west2-b) since yesterday afternoon. It’s still not working. Other online discussions suggest that 6 hours is a reasonable time to wait. But this exceeds that.

I have created a similar instance for east4 and that’s working, but it was a very time-consuming process since my notes on setup were inaccessible in the west2 VM.

Has Google been changing its allocation policies? Should fastai setup guide no longer advise everyone to select west2-b?

I’m seeing the same issue with my GCP instance. I found this link to move zones for existing instances but seems like a risky proposition… requires moving persistent storage and reattaching to new instance!

I’ve been experiencing the same issue since yesterday. Has anyone found a good solution, other than switching zones?

It’s working today! Quick, create your instance before it stops working again :slightly_smiling_face: other than that, I found this link to be excellent:

For each GPU, it tells you which zones offer it. Thus, since recommends using a P4, you can see that currently the zones equipped with it are

  • us-west2-c
  • us-west2-b
  • us-central1-a
  • us-central1-c
  • us-east4-a
  • us-east4-b
  • us-east4-c
  • northamerica-northeast1-a
  • northamerica-northeast1-b
  • northamerica-northeast1-c
  • europe-west4-b
  • europe-west4-c
  • australia-southeast1-a
  • australia-southeast1-b
  • asia-southeast1-b
  • asia-southeast1-c

Thus, when us-west2-b is not available (which is happening pretty often lately), you can start trying from us-west2-c and keeping moving further away geographically until you find a zone which has a P4 resource available. That’s what I do, and it works pretty fine for me.

1 Like

Thanks so much for your reply, @AndreaPi! Mine’s working today, too, but I’m grateful to have these instructions to fall back on if it goes wonky again.

1 Like