Deployment options (free tier) - Summer 2019 edition

I managed to deploy my first model, using Docker and Heroku’s free tier, but I’m wondering if there are any other free-tier options for Docker containers that might be better (including 1-year free tiers).

Heroku is great as a showcase, and it provides 1000 free hours which is more than enough for my one simple app, but it does take around 60-70 seconds to warm up if my app has been idle for more than 15 minutes. I can live with that, but I wonder if there are alternatives.

[The reason I started a new topic is that the previous relevant topic was crammed with hundreds of messages about Zeit Now, which seems to be no longer available.]

Here’s the app, by the way. It answers the age-old question “Is That a Capybara?”

1 Like

Hey Yotsuya!
I’m going down the same rabbit hole as you.
I found that the Zeit Now “loop hole” has been closed, which means we can’t deploy large models for free, it would seem
I got this email from them:

Deployment failed with the following error:
You tried to create a Now 1.0 deployment. Please use Now 2.0 instead:

I’ve tried to deploy to Heroku, but the deploy is failing with “slug size too large” error.
Since the Resnet50 model is about 300mb itself, I can see why the slug would get large, but mine is around 1Gb.
How big is yours?
I’m now going to try deploying my container to Kubernetes or something on GCP.


I was able to deploy to deploy a ResNet50 model on the free tier of Heroku. 1 GB is way too big to be a ResNet50 model. Something might be wrong if your model is that big.

Thanks for getting back.
I’ve just managed to deploy a docker image to Heroku.
I assume the 1Gb was all of the python dependency tree. The model itself was only 300Mb.
Anyway, while deploying the python server directly didn’t work, the container route did! :heart:



Ah sorry I missed this thread, but congratulation on finally getting it working!

I’m going to check out Python Anywhere next. I just finished my first project in Flask, so I’m a little more confident than I was a couple of months ago.

Hello guys, I’m new here. Please I’m in dire need of a working image to deploy a fastai model to heroku. Would appreciate any help. Thank you.

If you’re using fastai v1 (you’re in the 2019 forum right now) then you’ll have to edit the requirements.txt to get v1 instead of V2.

I believe fastai==1.0.61 --force should do it but if it doesn’t you’ll need to investigate.