Chapter 2: App Deployment errors

I have trained m model using Colab but since I could not install voila on colab, after exporting my model I have created my app’s notebook on jupyter. Every time I try to run the notebook on jupyter I get this error

and when I try to deploy the app on Binder I get a 404 Error saying that the notebook is not found.

Has anybody encountered this problems before? Is there something I am doing wrong?
Any help would be appreciated

did you import packages? like,
from import *

This post really helped me deploy using Binder

1 Like

the guide was really helpfull, my repository was actually missing a requirements text file!
I still got the 404 Error but if i go to the jupyter notebook anc click on voilathe app seems to work.

I’ll try to solve this problem

Thank you again

I have finally solved all the problems I had and managed to deploy my first app.
Even after creating a requirements text file I could not deploy my app succesfully, I tried deploying it with Eroku but I was unsucessfull. Then I figured out that maybe since I was using resnet34 for my model intead of resnet18 the image created by bynder was to big to be deployed on a free account.
I trained a new model with resnet18 and everything worked out.
I hope this could help somebody.

this is the link to my first app: