Can't start Jupyter Notebook Through Conda

Hi everyone!

This is more of a setup question, but I’ve been trying to set up the jupyter notebook on a remote machine. I had it installed and it was working fine so that I could do the ssh tunneling, but I realized I needed to have the Anaconda version for certain packages and such, so I ended up downloading Anaconda2 to my home directory. I’ve checked the ‘which jupyter’ commands and such to make sure everything is in the correct place and it all looks fine, but when I run the command ‘jupyter notebook’ now, I get this error:
‘ImportError: cannot import name ensure_dir_exists’
Above it, there’s another line that reads:
’.local/lib/python2.7/site-packages/notebook/", line 27, in
from jupyter_core.utils import ensure_dir_exists’
I’ve uninstalled and reinstalled Anaconda2 a number of times, and tried things like just uninstalling and reinstalling jupyter but can’t seem to get past this. Does anyone have any idea what this might mean or what I can do about it?