Can't setup environment on linux

I’m trying to setup the environment to start lesson 1.

Instead of using paperspace, i want to use my own linux virtual machine (i have a NVIDIA GPU), and i tried running the same script but nothing seems to work out.

I’m installing linux 16.04, tried on both processors version and also on version 18.

After a while fixing little errors, i managed to run the entire script error free, but now when i try to login on my virtual machine, i enter the password for my account, the screen flashes, and the login screen comes back up, getting me stuck in a loop.

Looking at the .xsession-errors on the console i noticed a GPU error:

Major opcode of failed request: 154 (GLX)

This one i couldn’t figure out what i was doing wrong.

What should i do to be able to login on my machine and start the course?

What nvidia driver are you using?

I haven’t installed the drivers yet, it’s a brand new virtual machine. Will create a new one, install the drivers and then run the script, it might take a while, but i will reply if everything works out! Didn’t realize it could be the cause of the problem

Thank you very much for now

I tried manually installing but it didn’t work out. Appearently the setup file provided on the course install the lastest nvidia-drivers, which is the 410 i guess. Tried running on a brand new virtual machine cleaning all the nvidia drivers before running the script, but the problem persists. Should i try on 18.04? Or should i try something else?

When you say linux 16.04, are you using ubuntu? The host, is it a windows host or linux host?

You may need to install something like “guest additions” to give the virtual machine access to the GPU. Another option is running ubuntu inside of windows in a more native way.

Maybe this will help:

Sorry for the ambiguity, my physical machine is a windows host, i’m installing everything on a Ubuntu 16.04 virtual. Will try installing guest additions and see if this works out