Can't import fastai2.tabular properly

Hi guys,

I tried to run a notebook I wrote last week, but I keep getting this error:

from fastai2.tabular.all import *
AttributeError: 'str' object has no attribute '__stored_args__'

Anybody facing the same?

Now that fastai is released, you should use fastai instead and upgrade your fastcore version. If not, check your fastai2 release version and install the same fastcore version that was released around the same time.

Pypi links for your convience:

fastcore fastai2

Hi @muellerzr,

I tried updating with: !pip install -U fastai2 but the error persists.

My versions are:
Successfully installed fastai2-0.0.30 fastcore-1.0.8

This is odd. Last week it ran just fine.

Well, it would be pip install -U fastai :wink: And please do check the versioning links I provided. The right versions are explicitly there if you check the release date of the latest fastai2 (which is heavily outdated since it’s now moved to fastai)

1 Like

Now it works ahahah. Thank you!