AttributeError: 'Image' object has no attribute 'new'

Hi everyone,
Recently I tried to train my model on ImageNet and I tried to use inception and Alexnet like preprocessing. I used Fast-ai imagenet training script. Pytorch has support for inception like preprocessing but for AlexNets Lighting, we had to implement this one ourselves :

__imagenet_pca = {
    'eigval': torch.Tensor([0.2175, 0.0188, 0.0045]),
    'eigvec': torch.Tensor([
        [-0.5675,  0.7192,  0.4009],
        [-0.5808, -0.0045, -0.8140],
        [-0.5836, -0.6948,  0.4203],

# Lighting data augmentation taken from here -
class Lighting(object):
    """Lighting noise(AlexNet - style PCA - based noise)"""

    def __init__(self, alphastd, eigval, eigvec):
        self.alphastd = alphastd
        self.eigval = eigval
        self.eigvec = eigvec

    def __call__(self, img):
        if self.alphastd == 0:
            return img

        alpha =, self.alphastd)
        rgb = self.eigvec.type_as(img).clone()\
            .mul(alpha.view(1, 3).expand(3, 3))\
            .mul(self.eigval.view(1, 3).expand(3, 3))\
        return img.add(rgb.view(3, 1, 1).expand_as(img))

which is finally used like this :

train_tfms = transforms.Compose([
        Lighting(0.1, __imagenet_pca['eigval'], __imagenet_pca['eigvec']),
    train_dataset = datasets.ImageFolder(traindir, train_tfms)
    train_sampler = (
                     if args.distributed else None)
    train_loader =
        train_dataset, batch_size=args.batch_size, shuffle=(train_sampler is None),
        num_workers=args.workers, pin_memory=True, sampler=train_sampler)

However, the problem is , whenever I run the script I get the:

‘AttributeError: ‘Image’ object has no attribute ‘new’’

Which complains about this line :
alpha =, self.alphastd)
What is wrong here ? what am I missing here? Can anyone please help me on this?