00_notebook_tutorial: Object `ImageDataBunch` not found

I am running through the notebook tutorial at the start of the Fast AI v3 course. Towards the end in the section marked Cell Tricks it demonstrates the use of ? and ?? to access documentation and code for the API.

However when I run this code, I get Object ImageDataBunch not found. instead of output. I have executed the preceding import lines so that doesn’t seem to be the problem, and I had no trouble with the code earlier in the lesson.

Searching the documentation I’m wondering whether ImageDataBunch has been deprecated and that is not reflected in the v3 course.

I did git pull in the course-v3 directory to check I have the latest, is there something else I’m missing?



I tried this:
import fastai *
import fastai.vision *

But it gave an error, so I had to change the last line to
import fastai; fastai.__version__

I don’t understand why this is needed but it gives 2.1.5 as the version I’m running.

Given that ?ImageDataBunch didn’t work I thought I’d try ?Image and this does work, but doc(Image) says doc is not defined.




I discovered that from {library} import * does not include objects that start with _ which explains why I needed to explicitly import __version__.