Since Tensorflow-GPU requires CUDA 9.0 and not 9.1, is there any way to run it concurrently with Fast.AI (on Paperspace)?


#1

I’ve tried running Tensorflow-gpu on my Paperspace instance where I installed Fast.AI but got error messages each time. Can’t remember what they were but I later found out that it’s because I’m running CUDA 9.1 but the latest Tensorflow (1.6) still will only run on CUDA 9.0.

Is there any way I can get both Fast.AI AND Tensorflow to run on the same Paperspace instance, perhaps by installing both CUDA 9.1 and 9.0?


#2

You can compile Tensorflow from source. That’s what I’ve been doing on my personal desktop machines, which currently have CUDA 9.1.


(Sritanu Chakraborty) #3

How did you install tensorflow-gpu on paperspace? conda install? compiled from source? pip install? I guess the fastai venv/paperspace machine is using conda python. You can do a quick check which python env your system is using. If its conda python, then I guess installing tensorflow-gpu from conda would solve the problem. Again, it would be much more helpful if you can provide screenshots/exact errors.


#4

I highly doubted installing from conda instead of pip would make any difference but I tried anyways:

pip uninstall tensorflow-gpu
conda install -c aaronzs tensorflow-gpu 

Note only aaronzs has a version of tensorflow-gpu over 1.5 on the Anaconda Cloud since any version under 1.4 can’t be run on Cuda 9.

And sure enough, this version still gives me the same error.


(Sritanu Chakraborty) #5

Can you post a screenshot of the error that you are getting?


(Sritanu Chakraborty) #6

And seems like people are facing lot of problems with cuda 9.1. There are even recent issues opened on github. Please go through the following:

  1. https://github.com/tensorflow/tensorflow/issues/15656 [second last comment of gunan]

  2. https://github.com/tensorflow/tensorflow/issues/15140

May be you can try building from source as jeff suggested above.


#7

Yes, it worked now!

I followed this guide.

But jumped straight to the Bazel section (since most of the libraries were already preinstalled.)

After finishing that section, jump back down to the “Tensorflow Install” section and run those

Make sure when you go to /tmp/tensorflow_pkg you install the right .whl file, not the one in the example.

If anyone wants the .whl, I can probably post it to Github or Dropbox but I can’t guarantee it’ll work on yours though the chances are better if you’re also using Paperspace.


(Daniel) #8

Just a quick update: There’s a new version of our ML in a Box template that includes CUDA 9. It’s based on a slightly newer version of TensorFlow (1.7) but hopefully that shouldn’t be a problem. We won’t be updating the Fast.ai template yet as Jeremy manages it but you can use his script to pull down the Fast.ai requirements into the ML in a Box template.

Hope that helps.