Setup problems: AWS


(Will Kriski) #318

I got this error as well. Based on the PendingVerification 2 hours error I would assume it’s on Amazon’s side. I might try to start over as suggested if I don’t hear from Amazon.


(Will Kriski) #319

Update: I had to request the P2 instance as recommended in the video. Amazon phoned me. I saw the P2 in the EC2 server list on the website so I assumed it was available now in 2017 without a request.


#320

When I run the command bash setup_p2.sh, I get the following error:

True

An error occurred (InvalidKeyPair.NotFound) when calling the RunInstances operation: The key pair ‘aws-key-fast-ai’ does not exist

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start…

Waiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws: error: argument --instance-id: expected one argument

An error occurred (MissingParameter) when calling the RebootInstances operation: The request must contain the parameter InstancesSet

All done. Find all you need to connect in the fast-ai-commands.txt file and to remove the stack call fast-ai-remove.sh
Connect to your instance: ssh -i /Users/svonpfefer/.ssh/aws-key-fast-ai.pem ubuntu@None


(jrheard) #321

I see the same output as @svonpfefer.

I’m on OS X, and am using a preexisting anaconda install with python 3.5 - is that relevant?

~/.ssh/aws-key-fast-ai.pem exists but is empty, which seems like it might be unusual.

UPDATE: removing that file and trying the script again seems to have resolved the issue.


(orl) #322

after i installed:
$ pip install awscli

i got this message:
$ aws
-bash : aws: command not found

but when i write aws.cmd i got:

how can i fix it?


(Frank) #323

Hello, I got following error when setting up setup_p2.sh on windows 10

: Permission denied: /dev/null
setup_p2.sh: line 129: syntax error: unexpected end of file

can anyone help?

I have edited setup_p2.sh in notepad which has only 128 lines.


(Jae) #324

I’m still confused about whether t2.micro or t2.large is a free service instance? In the ‘AWS intall’ wiki page, the author mentions t2.large, but in the ‘Lesson 1’ video, the other author mentions t2.micro as a free service instance. So which one to request and use for testing purpose without being charged 0.90/hr rate?


(Jae) #325

I found my answer from ‘Lesson 1’ wiki. Here a copy and paste from the page:

The free t2.micro instance type recommended in the lesson does not have enough RAM to use the VGG16 model. To switch to t2.large, which has enough memory (but costs $0.10/hour) see the Change EC2 Size page


(orl) #326

someone?


(orl) #327

I tried 2 install aws for a week by now…

i’m really clueless…maybe someone could help me through SKYPE?


#328

For other guys who may have the same AuthFailure errors: before you run setup_p2.sh script make sure the time on your computer is properly synchronized.


(D) #329

@orl

I would check out this page: http://docs.aws.amazon.com/cli/latest/userguide/installing.html

specifically try
"pip install --upgrade --user awscli"


(orl) #330

thanks @KradocD

but i still keep getting:

somehow it is only recognize aws.cmd and not aws…


(paul harmer) #331

I am trying to set up my aws account and keep getting this message below - no matter what region I select. Does anybody know why ?

Also, I have found the ami that the script install in the instances community options - so I can set that up from the console but I dont know what else I would need to do to get it running - is there a step by step guide to set up without the script?

Thanks in advance ,

regards

Paul


(Fernando Barbosa) #332

I had the same issue and it seems that downloading and installing awscli with the .msi installer provided by amazon has solved that problem. I does take a little longer than using pip install but it got me set up. I hope it helps.


(paul harmer) #333

Hi Nandevers,

Thanks for the info. I will give it a try. Did you have to start from fresh to get it to work?
Regards
Paul


(paul harmer) #334

Hi,

Sorry further to my last question - how did you run the script after the msi installer - still in Cygwin?

Thanks
Paul


(Fernando Barbosa) #335

I didn’t. I went to Amazon’s aws web page and downloaded it.


(Fernando Barbosa) #336

Although I have tried my best I keep on running into small yet very tyring problems with setup. Now, I can get setup_t2.sh to work despite all the reading. I wish there was an easier way. Syntax seems to be messed up there and all the variables with “$” wont work… I tried running the script line by line and replacing the variables by the values I got from aws. However, every now and then there is something I can’t get through. Any advice (Windows 10 + Cigwin). PS. I hate Windows 10… but that’s what I can do at the moment. Time-wasting and patience-burning setup.


(Girija) #337

Hi, I am getting similar problem while setup.

I tried as suggested by you.also followed “https://medium.com/africa-ai/how-to-set-up-aws-p2-server-for-deep-learning-abf8f8dc7948#.bcqsql2ta

I am getting the following error.

$ bash setup_p2.sh
setup_p2.sh: line 7: syntax error near unexpected token newline' setup_p2.sh: line 7:

could you please help me?
regards,
Girija