Setup problems: AWS


(Chinta) #228

Hello forum, I have been able to connect to ubuntu, but when I type nvidia-smi, getting the below error.

ubuntu@ip-10-0-0-11:~$ nvidia-smi
nvidia-smi: command not found

Have used the script setup_t2.sh.

Can connect to notebook, but import of theano returning error.

ImportError Traceback (most recent call last)
in ()
----> 1 import theano

/home/ubuntu/anaconda2/lib/python2.7/site-packages/theano/init.py in ()
61 object2, utils)
62
—> 63 from theano.compile import (
64 SymbolicInput, In,
65 SymbolicOutput, Out,

/home/ubuntu/anaconda2/lib/python2.7/site-packages/theano/compile/init.py in ()
7 SpecifyShape, specify_shape, register_specify_shape_c_code)
8
----> 9 from theano.compile.function_module import *
10
11 from theano.compile.mode import *

/home/ubuntu/anaconda2/lib/python2.7/site-packages/theano/compile/function_module.py in ()
16
17 import theano
—> 18 from theano import config, gof
19 from functools import partial
20 from theano.compat import izip


(Alex) #229

Hi Suresh,

nvidia-smi command is baked into the AMI the instance is created from. Can you share the AMI for you instance from AWS Web Console?

Were there any errors while running setup_t2.sh script?


(Chinta) #230

Thanks for your reply.

Here are the ami info. No error in set up script at the end, I have fixed the an error that came. Is the best course of action is to start running the script again, by deleting the existing instance ?

fastai-dl-02 (ami-f8fd5998)
Description
fast.ai non-gpu deep learning image
Status
available
Platform
Other Linux
Image Size
128GB
Visibility
Public
Owner
191578494129


(Chinta) #231

Thanks again Alex, I have executed the bash script by copy pasting the commands one by one from git hub, as wget was giving some issues.


(Cherie Chin-A-Fo) #232

Thank you Rachel. I will have a look where I found the reference to the Ireland links.

I checked and my region is set to eu-west-1. When I run the setup_p2.sh file I get the following error:
I am using Linux for Windows10 and am getting the following error when I run setup_p2.sh.

'aws: error: argument subcommand: Invalid choice, valid choices are:

list
setup_p2.sh: line 10: [: =: unary operator expected
setup_p2.sh: line 12: [: =: unary operator expected
setup_p2.sh: line 14: [: =: unary operator expected’

Do you have any suggestions on how to resolve this?

With best regards,
Cherie


(Chinta) #233

please help me on this.


(Tyler LeCouffe) #234

I’ve just had the same error. Any luck?


#235

Hey Mark, I ran into the same issue, was just wondering if you eventually had success/did it require any further action on your end? Thanks a lot in advance.

Cheers,
Chris


(Josh Zastrow) #236

Hi there,

Hit a roadblock setting up the t2 instance (8:51 min into the AWS Setup video – downloaded the setup_t2.sh script instead of the setup_p2.sh because I’m still waiting on P2 approval).

ran bash setup_t2.sh , got 'syntax error near unexpected token ‘new line’

Couldn’t find any previous posts that ran into this problem, so I figured I’d post it here and hope someone can shed some light on the matter.

Note the image shows setup_t2.sh.1 because I made two attempts at downloading and running the file

I tried to do an

apt-cyg install dos2unix

and run the setup file with dos2unix instead of bash

dos2unix setup_t2.sh

but that did not work ( just said converting file to unix format… then nothing, bash still didn’t work afterwards)

Thanks for the help!
Josh


(Chinta) #237

You may copy paste each line of code in awscli, instead of doing wget and bash.


(Josh Zastrow) #238

like line by line into the cygwin terminal?


(Chinta) #239

yes please.


(Josh Zastrow) #240

seems like it’s hung up (line 59)… I’m no longer getting the new line $. Maybe I’m just impatient


(Chinta) #241

Hello there is an error message even above the wait, it tells your account is yet to clear verification process.


(Cherie Chin-A-Fo) #242

Hi Tyler,

I changed the setup_p2.sh and setup_t2.sh files. I commented out the if statements and added in a line with the ami for Ireland so that part of the code (from line 10) looks like this:

# if [ "$region" = "us-west-2" ]; then # export ami="ami-bc508adc" # Oregon # elif [ "$region" = "eu-west-1" ]; then # export ami="ami-b43d1ec7" # Ireland # elif [ "$region" = "us-east-1" ]; then # export ami="ami-31ecfb26" # Virginia # else # echo "Only eu-west-1 (Ireland) and us-east-1 (Virginia) are currently supported" # exit 1 # fi export ami="ami-b43d1ec7"

This is just a quick solution to get the setup files to work.

With best regards,
Cherie


(Josh Zastrow) #243

Hey Suresh,

Yes, waiting helped. Still not sure why the bash command didn’t work which bugs me a bit, but manually copying and pasting the code into the cygwin shell allowed me to continue forward.

Thanks for your help


(Cherie Chin-A-Fo) #244

Hi Josh,

I had that issue and was told to get the raw code from git hub. So try this link and see if it works for you too.

https://raw.githubusercontent.com/fastai/courses/master/setup/setup_t2.sh

Best regards,
Cherie


(Tim) #245

How long does it typically take to get approval for the GPU server? (I’m a new AWS user, on the free tier.) Thanks.


#246

Chris - yes they did approve my instance, shortly after I posted this. Maybe they don’t process requests on the weekend, because they got back to me fairly early Monday morning and I submitted my request Sat night.


(daniel a. aronson) #247

I am trying to use emacs on my GPU instance, but the package manager can’t find the package. Any ideas?

root@ip-10-0-0-9:~# emacs
The program 'emacs' can be found in the following packages:
 * emacs24
 * emacs24-nox
 * e3
 * emacs24-lucid
 * jove
Try: apt install <selected package>
root@ip-10-0-0-9:~# apt install emacs24-nox
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package emacs24-nox