Problems with updating conda and git pull


#1

This the message after trying to update conda:

conda env update
Using Anaconda API: https://api.anaconda.org

SpecNotFound: Can’t process without a name

Also, is this OKay after git pull in fatsai repo?:

git pull
emote: Total 643 (delta 378), reused 379 (delta 378), pack-reused 264
Receiving objects: 100% (643/643), 1.29 MiB | 0 bytes/s, done.
Resolving deltas: 100% (411/411), completed with 69 local objects.
From https://github.com/fastai/fastai
e8841f7…8abb7b0 master -> origin/master

  • [new branch] ulmfit_cleanup -> origin/ulmfit_cleanup
    Updating e8841f7…8abb7b0
    error: Your local changes to the following files would be overwritten by merge:
    courses/dl1/lesson1.ipynb
    courses/ml1/lesson1-rf.ipynb
    Please, commit your changes or stash them before you can merge.
    Aborting

#2

The first one (about conda update) solved, still not sure if git pull works correctly.


(Gerardo Garcia) #3

That’s usually because you modified some of the notebooks on your folders.
rename the notebooks that you modified and try again.

If you do the other instruction commit or stash


#4

Thanks, solved


(Peter Straka) #5

lion137, how did you solve the SpecNotFound error?


#6

I think, Czech mistake:), I didn’t provide enviroment file enviroment.yml. On my computer:
conda env update -f environment-cpu.yml


(Maziyar) #7

I could do git pull and it worked after git stash but I still get the error SpecNotFound: Can't process without a name when I run conda env update.
I also tried what @lion137 said conda env update -f environment-cpu.yml but I get the same error

I appreciate any help


(Maziyar) #8

I solved the first problem:
conda env update should run not from the fastai directory but from the parent directory.
The new problem I have after update is the following :
I get the warning

to activate this envirounment use:
source activate fastai

and when I tray to run this command I get the following error:

source: not found

after some searches I tried :slight_smile:

conda activate fastai

I also get error:

CommandNotFoundError: Your shell has not been properly configured to use 'conda activate'.
If your shell is Bash or a Bourne variant, enable conda for the current user with

$ echo ". /opt/conda/etc/profile.d/conda.sh" >> ~/.bashrc

or, for all users, enable conda with

$ sudo ln -s /opt/conda/etc/profile.d/conda.sh /etc/profile.d/conda.sh

The options above will permanently enable the 'conda' command, but they do NOT
put conda's base (root) environment on PATH. To do so, run

$ conda activate

in your terminal, or to put the base environment on PATH permanently, run

$ echo "conda activate" >> ~/.bashrc

Previous to conda 4.4, the recommended way to activate conda was to modify PATH in
your ~/.bashrc file. You should manually remove the line that looks like

export PATH="/opt/conda/bin:$PATH"

after trying all the above mentioned command I still cget the same error as above after running the command.

I also tried:

activate conda

and it also give me the error:

/bin/sh: 8: activate: Permission denied

P.S. I use Paperspace
any help is appreciated