Problems with updating conda and git pull


#1

This the message after trying to update conda:

conda env update
Using Anaconda API: https://api.anaconda.org

SpecNotFound: Can’t process without a name

Also, is this OKay after git pull in fatsai repo?:

git pull
emote: Total 643 (delta 378), reused 379 (delta 378), pack-reused 264
Receiving objects: 100% (643/643), 1.29 MiB | 0 bytes/s, done.
Resolving deltas: 100% (411/411), completed with 69 local objects.
From https://github.com/fastai/fastai
e8841f7…8abb7b0 master -> origin/master

  • [new branch] ulmfit_cleanup -> origin/ulmfit_cleanup
    Updating e8841f7…8abb7b0
    error: Your local changes to the following files would be overwritten by merge:
    courses/dl1/lesson1.ipynb
    courses/ml1/lesson1-rf.ipynb
    Please, commit your changes or stash them before you can merge.
    Aborting

#2

The first one (about conda update) solved, still not sure if git pull works correctly.


(Gerardo Garcia) #3

That’s usually because you modified some of the notebooks on your folders.
rename the notebooks that you modified and try again.

If you do the other instruction commit or stash


#4

Thanks, solved


(Peter Straka) #5

lion137, how did you solve the SpecNotFound error?


#6

I think, Czech mistake:), I didn’t provide enviroment file enviroment.yml. On my computer:
conda env update -f environment-cpu.yml