Paperspace setup help


(Sanyam Bhutani) #21

Did anyone try running the setup on GCP?
Many of the people from AI Saturdays community, were interested in exploring GCP as an option-because of the 300$ credits.

Can someone point me to the steps to setting up on GCP?


(Aswadi) #22

I setup the paperspace using Ubuntu 14.04 (ML-in-a-box) for fast.ai and conda env update. Looks like 50GB is not enough. maybe I should installed from fresh ubuntu 14.

update:
I delete the old vm and create a new machine with Ubuntu 16 and run

curl http://files.fast.ai/setup/paperspace | bash

the problem now is that my jupyter notebook can’t access from outside. let try to figure out why

update:
ok. now it’s working after I change jupyter config in below link setting paperspace jupyter

btw for those that try using paperspace better using below steps.

  1. pick Ubuntu 16 + 50GB
  2. run @jeremy bash code
  3. configure back the jupyter using link
  4. if everything works you will have additional 40GB to play around.

(Aditya) #23

Head over to forum of previous version of this course…
You will get what you want…(but with certain tweaks…)


#24

For someone keen on using paperspace you can actually get max 30$ credit from paperspace

First create the account via Fast AI Promo link

https://www.paperspace.com/&R=FASTAI15

Once account is created go to Billing, Don’t add your credit card as of now just go to billing

add this as promo code DDQRI0U you would get 10$

Now on the Machine tab create your machine as instructed in the video

Below the credit card tab there is another promo tab

add this as promo code HNGPU5 you would get another 5$

once you do this then add your credit card details. You would have 30$ to play with your machine remember as soon as the machine is created you are charged 5$ for storage and 3$ for public IP


(Seema Goel) #25

Hi,
I am trying to setup Paperspace machine and it is showing me Error code 214.
Did anyone encounter this?


(Radi) #26

Is papersapce in place of the AWS setup? Is there are part 1 (v2) setup video?


(emsart) #27

has anyone experienced billing difficulties with Paperspace, when using an international credit card ? If so, how have you solved the difficulty ?


(Christina Entcheva) #28

@Seema - yes, I had the same issue. I created a new machine and it provisioned just fine in less than a minute. Have you tried creating a second VM?


(Reshama Shaikh) #29

I wrote up instructions Paperspace for fastai

I was able to get the Jupyter notebook up and running. However, when I ran the notebook, I ran into errors.
When running the second cell, which is:

# This file contains all the main external libs we'll use
from fastai.imports import *

I get the following errors:

---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-2-c51a52575a56> in <module>()
      1 # This file contains all the main external libs we'll use
----> 2 from fastai.imports import *

~/fastai/courses/dl1/fastai/imports.py in <module>()
      1 from IPython.lib.deepreload import reload as dreload
----> 2 import PIL, os, numpy as np, math, collections, threading, json, bcolz, random, scipy, cv2
      3 import random, pandas as pd, pickle, sys, itertools, string, sys, re, datetime, time
      4 import seaborn as sns, matplotlib
      5 import IPython, graphviz, sklearn_pandas, sklearn, warnings

~/anaconda3/envs/fastai/lib/python3.6/site-packages/cv2/__init__.py in <module>()
      2 import os
      3 
----> 4 from .cv2 import *
      5 from .data import *
      6 

ImportError: libSM.so.6: cannot open shared object file: No such file or directory

#30

Unfortunately your setup has not completed successfully.

For some weird reason paperspace breaks the setup midway sometimes.

One of the ways to figure out whether your setup has completed successfully or not is to see
the jupyter launch url that is shown when you run jupyter notebook

http://localhost:8888/?token=a6942d5fb64c5b17a7ea5a2206662a7c9098a903068a3778

here it should not be localhost —> it should rather be —> [all ip address in your system]

this is because if you see the setup scripts

jupyter notebook --generate-config
echo “c.NotebookApp.ip = ‘*’” >> ~/.jupyter/jupyter_notebook_config.py
echo “c.NotebookApp.open_browser = False” >> ~/.jupyter/jupyter_notebook_config.py
sudo ufw allow 8888:8898/tcp

here we are allowing the notebook to be accessible to all the ip in the system and hence you should be able to access notebook externally

other easy way to check if the scripts have run successfully, is to look for below message at the end of the setup

echo —
echo - YOU NEED TO REBOOT YOUR PAPERSPACE COMPUTER NOW
echo —

so if you have not seen this echoed in your terminal then scripts have not run completely


(Reshama Shaikh) #31

thanks @aseem
Can I just rerun the command curl http://files.fast.ai/setup/paperspace | bash
or is there a way to remove all that is installed?
I’d like to avoid deleting the machine, so I won’t have to pay the $5 again for storage.


#32

Actually my mate had same issues,

can you please tell me if you have the anaconda installed properly

anaconda --version

and also have the data folder with dogscats unzipped


(Reshama Shaikh) #33

I tried turning machine on and off in Paperspace.
And then I reran the bash script. And then, the remote connection was lost in the middle.
(this is not a problem we encounter with AWS).


#34

Yeah well with AWS there are other issues, luckily for us Paperspace is straight forward.

Only issues i found was that Paperspace terminal is bugged , i have seen people having problem starting and restarting the machine and scripts breaking in between.

If you want to use the same machine , then best way would be to track the point where the scripts have run successfully . Or at least thats what i did !

Can you let me know if the anaconda version was installed and if the data folder was created with the unzipped first lessons files in it ?

because i know that your system has not created the jupyter config yet. So i can guide you from the last successful script execution


(windalfin) #35

Unfortunately Paperspace can’t be used by Indonesian student due to a lot of fraud coming from Indonesia, they choose not to allow payment from here. Will be looking at floydhub as alternative here.


(Nathan Yee) #36

I see it highlighting bcolz, try doing:

  1. source activate fastai
  2. pip install bcolz

(Jeremy Howard) #37

Try using ssh to connect to paperspace instead of using their in-browser terminal.


(Seema Goel) #38

Thanks @entcheva for replying, I didn’t try creating another machine.
As you, Paperspace support suggested creating another machine. Will try that and update.


#39

Yeah as Jeremy pointed out . For a bug free installation it is better to ssh into the instance and then install everything from your ssh machine terminal rather than using their browser ones.


(Tom Brown) #40

@radi depending on your geographic location the suggestion is paperspace over AWS.

I found what appears to be the setup instruction at 6:19 into the first class video.

Hope this helps.