How to set up AWS for Part 1 v2


(naveen manwani) #22

yes in my case i created a id_rsa file which is id_rsa.pem file


(naveen manwani) #23

actually i don’t want to use putty for the moment .i want to connect it with my local computer.and changing wifi connection didn’t resulted in any change


(naveen manwani) #24

even i tried with putty ,the black screen come for a while ,then a block appear network error ,connection time out.have you faced this error .if yes how did you resolved it


(Reshama Shaikh) #25

@naveenmanwani What time zone are you in? I can get on a zoom call and guide you through it. Wed and Thurs I am completely unavailable, perhaps sometime today or on Friday.


(naveen manwani) #26

thank you mam for your kind gesture but just few minutes back i solved my problem ,actually it was because of my router i was facing this problem of port 22 unavailable,i don’t why my router didn’t not allowed me to establish connection from port 22,but as being said quitter never wins and winner never quit .therefore as soon as i switched to my phone internet connection things worked pretty nicely and then i followed your guide to open the jupyter notebook


(Saurabh Jha) #27

I tried to launch the AWS fastai EC2 instance, i got the below error message, please advise.

Please find the error message below:

Launch Failed
You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.
Hide launch log
Creating security groups

Successful (sg-722c830e)
Authorizing inbound rules

Successful
Initiating launches

FailureRetry


(Jeremy Howard) #28

You need to click on the link in that message and request access to that instance type.


(Saurabh Jha) #29

thanks Jeremy

I have already raised a request with amazon support, they have not yet responded, let’s see how soon it gets sorted out


(Edwin Lee) #30

Hi all,

Anyone faced similar problems running the first training model for dogs and cats on AWS in the 2018 version of the course after setting up the instance fine, and running Jupyter Notebook?

These are the steps I took.

  1. I used the setup script setup_p2.sh and managed to get an instance running on AWS. No problem.

  2. I ssh’ed into the machine and run every line of code in http://files.fast.ai/setup/paperspace in my AWS instance manually. This looked fine too on the surface.

  3. I started Jupyter Notebook and ran lesson1.ipynb. Worked fine.

  4. This is where the problem arose. I shift-enter’ed all the steps (waiting for each to complete running first before running the next block) until this block:

arch=resnet34
data = ImageClassifierData.from_paths(PATH, tfms=tfms_from_model(arch, sz))
learn = ConvLearner.pretrained(arch, data, precompute=True)
learn.fit(0.01, 2)

I ran it and it got stuck after downloading resnet34. I waited for more than 10 mins and nothing happened.

Thereafter, I reloaded Jupyter Notebook and ran each block again until I reached the resnet34 block. I ran it and then it gave a different error.

RuntimeError: cuda runtime error (2) : out of memory at /opt/conda/conda-bld/pytorch_1512387374934/work/torch/lib/THC/generic/THCStorage.cu:58


(Jeremy Howard) #31

You should restart your kernel since your GPU is out of memory.


(Masum Hasan) #32

Hi! I have written a comprehensive guideline for setting up and running fastai on Amazon AWS. Hope it would be helpful. Please let me know if any modification is necessary.


(Pierre Guillou) #33

Great post @Masum !
I just published one that answers the question : how to setup fastai in an Amazon AWS region without fastai AMI like in Europe :slight_smile:


AWS AMI available for testing
Script to provision AMI from base AMIs
(Dylan Kenyon) #34

Hello everyone! I am trying to set up AWS for Part 1 v2 as well, but when search for ‘fastai’ in the community AMIs there are no results. Has anyone else had this problem? Or are these instructions already out of date somehow?