Free GPU credits for Fast.ai Courses


(Edward) #82

Thanks for the service and credits!
I’m new to to this environment and am having trouble getting snark to run from windows using Anaconda. Everything installed fine and I managed to start up a pod, but I get en error from my anaconda prompt as it cannot find ssh. Windows does not have ssh by default and microsoft has a beta version of ssh which i currently cannot install on my device. Any suggestions? Is there a workaround in Anaconda?


(Phaneendra Gunda) #83

I am getting the following error
“Setting up the pod…
Connecting to the pod…
‘ssh’ is not recognized as an internal or external command,
operable program or batch file.”

I am running on Windows environment.


(Alexandros Evangelou) #84

i am tryn to run snark start --pod_type fast.ai --jupyter
but i have this error
Setting up the pod…
Connecting to the pod…
no kex alg


#85

@derekchia can you message me your username? I’ll take a look. But looks like you have to stop the pod and restart it again.


#86

Hi @abavish, you have a fixed amount of credit which translates into 100 hrs of P106 OR around 50 hrs of 1080. When you’re using P106, the total credit decreases so the equivalent hours of 1080 also decreases. Sorry for the confusion. We’ll put this in a FAQ shortly


#87

@Edward you may need to install ssh on windows http://sshwindows.sourceforge.net/


#88

@Phaneendra you would need to install ssh http://sshwindows.sourceforge.net/ on windows. Sorry about the inconvenience. We’ll note this in FAQ


#89

@evagelou hey can you clarify what is the problem here? Is kex alg some python package you were expecting?


#90

Got it! Thanks @snarkai!


(Alexandros Evangelou) #91

it was a problem of windows with the ssh. I just use the ubundu shell for windows and everything is fine. Thank you for your time and for your offer.


#92

I followed the steps until $snark start --pod_type fast.ai --jupyter but when I copy the URL in the browser for the first time it does not open the notebook. Please help.


#93

Hey @abavish did you use the 90ecc4fd24f9 OR 127.0.0.1? Please don’t copy paste the url as it is. Choose one and see which works. Sorry for the confusion. Adding it in FAQ.


(zhou fan) #94

@snarkai
I meet this error when I run lesson3-rossman.ipynb


and I tried to start 2 p106 gpus, but it didn’t help


#95

I tried it with 127.0.0.1:8888/?token=… and with 90ecc4fd24f9:8888/?token…as well, but it didn’t work. My usage kept on reducing though.


(zhou fan) #96

maybe you can try to stop it and start a new one


#97

Tried that, but didn’t work.


#98

@snarkai @XFFXFF Finally it worked, I restarted my laptop and it got connected! The basic of all troubleshooting steps worked :slight_smile:


#99

@snarkai Since you’ve installed pytorch 0.3 by default, I’m getting lib specific issues, many of them have been solved on 0.4. I want to upgrade it. I tried activating the fastai env but it threw an error. Could you please tell how to go about it?


(Rasul Kerimov) #100

Why do I have only 4GB of RAM on my NVIDIA P106-100 instance? BTW, thanks for the free hours.

Selection_049


(zhou fan) #101

fast.ai requires pytorch 0.3