AWS AMI available for testing


(Benjamin DeKoven) #21

I chose t2.micro without paying attention to the AMI description.

I had to put in a request to AWS for access to p2.xlarge.

Thank you @claytonjy for these suggestions!


(Aditya) #22

is it based on geo-location or anyone can access it?
Like if i set my region to US West?


(Ramesh Sampath) #23

You need to spin up your machine in US West Oregon Region to use the AMI. Anyone can run a machine in any EC2 regions. But you need to remember where you spin up your instances, so you can stop it when not using it. EC2 dashboard has no “Global” View. You have to choose the view from the dropdown in the top right. So be careful and I would suggest you just stick to US West Oregon for all instances. US Regions typically have the lowest cost in AWS - https://aws.amazon.com/ec2/pricing/on-demand/


Getting set up on AWS for the course
(Vishal Pandey) #24

Hello All…
I launched the instance and ssh’ed into it through putty successfully . But I am not able to open jupyter notebook in my browser. It’s running into the instance but when I am trying to open it into my browser it doesn’t connect…


(Aditya) #25

have a look at the discussion ahead in this thread…


(Vishal Pandey) #26

Already tried all that… still not being able to open it.
Displays ERR_TIMED_OUT The site can’t be reached


(Aditya) #27

i am also having the same problem like them but i am using root user to do ssh…

root@DESKTOP-V3IQLHT:~/.ssh# ssh -i .ssh/aws_key_pair.pem ubuntu@ec2-35.161.145.248 -L 8888:127.0.0.1:8888
ssh: Could not resolve hostname ~35.161.145.248: Name or service not known

root@DESKTOP-V3IQLHT:~# ls -a
.  ..  anaconda3  .bash_history  .bashrc  .bashrc-anaconda3.bak  downloads  id_rsa_1  .local  .nano  .profile  .ssh
root@DESKTOP-V3IQLHT:~# clear
root@DESKTOP-V3IQLHT:~# ls -a
.  ..  anaconda3  .bash_history  .bashrc  .bashrc-anaconda3.bak  downloads  id_rsa_1  .local  .nano  .profile  .ssh
root@DESKTOP-V3IQLHT:~# cd .ssh/
root@DESKTOP-V3IQLHT:~/.ssh# ls
aws_key_pair.pem  id_rsa_1.pub

What Should i do?
@ramesh

Update

ssh is successful with this one though

root@DESKTOP-V3IQLHT:~# ssh -i .ssh/aws_key_pair.pem ubuntu@ec2-54-70-111-75.us-west-2.compute.amazonaws.com

(Chan Sooi Loong) #28

Just spin up the instance p2.xlarge at US:west Oregon. SSH into the instance, ran Git Pull, ran Notebook 1. And got the results just fine :slight_smile:

Thanks Jeremy for this awesome AMI !


AWS GPU install script and public AMI
(Clayton Yochum) #29

I think your issue originally was not using the right IP address; ec2-35.161.145.248 is neither a domain name nor an IP address, and I suspect 35.161.145.248 is your private IPV4 address, not the public one. Also, if you’re already in the .ssh folder, you don’t want the path to the private key to start with .ssh/. I usually give absolute paths (~/.ssh/aws_key_pair.pem) so I can re-run commands from history without caring what my pwd is.

Now that you’ve connected over SSH, you can see that tunnelling the jupyter-notebook port isn’t necessary to connect. If you do want to tunnel that connection over ssh, you can try the working ssh command again, but with -L 8888:127.0.0.1:8888 appended like you tried originally.


(Aditya) #31

Actually I just removed the ec2 and it’s working…

Getting this error while launching jupyter…

channel 3: open failed: connect failed: Connection refused

@ramesh


(Ramesh Sampath) #32

Basically the error means that no Application in your EC2 instance is listening on port 8888. Did you start Jupyter notebook inside the Remote machine?

Try the command jupyter notebok list, if there’s jupyter server running in EC2, you will see it, otherwise it will come up empty. If it’s empty run Jupyter Notebook.

Because you are using Tunneling of ports, if for any reason you loose the SSH connection, your notebook is not accessible. It might be better to open up port 8888 on the server by modifying the Security Groups (on EC2) and then directly connect via http://<ec2-servername>:8888


Anyone able to run the Lesson 1 notebook?
(Aditya) #33

Thanks for the info…


(Amrit ) #34

wrong thread


(Jayant Raj) #35

I was able to create a p2 instance with this AMI and run through the lesson 1 notebook without any errors. As Jeremy mentioned, you need to do a git checkout & git pull inside your local repo.

@jeremy Would you be able to provide a rough outline of what software packages you installed in the AMI and in what order? It would serve as a great confidence booster to set this up on my own instance from scratch. Appreciate your attention to this request!


(Rikiya Yamashita) #37

Worked well for me!

As @claytonjy mentioned, I also needed to do below.

Thanks a lot @jeremy :slight_smile:


(K Sreelakshmi) #39


This is what i get when i try creating the instance? What should i do? @jeremy


AWS GPU install script and public AMI
(yinterian) #40

Request for a limit increase to 1. Mention fast.ai course.


(K Sreelakshmi) #41

Will do that! Thanks


(Benjamin DeKoven) #42

I put in the request for EC2 limit increase to p2.xlarge on Thusday evening (US date). Hopefully the approval for the increase will come soon.

Ben


(K Sreelakshmi) #43

How long will amazon take to update our request instance for p2.xlarge? any other option to do the lesson 1 notebook because my crestle is also not running well enough.